Задать вопрос
1 марта, 11:42

Текущее показание электронных часов: m часов (0<=m<=23) n мин (0<=n<=59), k c (0<=k<=59). Какое время будут показывать часы через p часов, q мин, r c?

+2
Ответы (2)
  1. 1 марта, 11:57
    0
    Uses crt;

    function

    Conv (x:byte) : string; {функция преобразования чисел в строку (маска вывода) }

    var

    s, t:string;

    beginstr (x, t) ; {преобразуем число в строку}

    if x=0 then s:='00'{если это ноль}else

    if (x>0) and (x<=9) then s:='0'+t

    {если однозначное число}

    else s:=t; {двухзначное число}

    Conv:=s;

    end;

    var ch1, mn1, sc1:byte; {начальное время}

    chd, mnd, scd:byte; {добавленное время}

    chr, mnr, scr:byte; {результат}

    mn, ch:byte; {добавление 1 к минутам и часам, если секунд или минут >60}

    begin

    clrscr;

    writeln ('Vvedite nachalnoe vremya:') ;

    write (' Chasy=') ;

    readln (ch1) ;

    write (' Minuty=') ;

    readln (mn1) ;

    write (' Secundy=') ;

    readln (sc1) ;

    writeln ('Vvedite pribavlennoe vremya:') ;

    write (' Chasy=') ;

    readln (chd) ;

    write (' Minuty=') ;

    readln (mnd) ;

    write (' Secundy=') ;

    readln (scd) ;

    scr: = (sc1+scd) mod 60;

    mn: = (sc1+scd) div 60;

    mnr: = (mn1+mnd+mn) mod 60;

    ch: = (mn1+mnd+mn) div 60;

    chr: = (ch1+chd+ch) mod 24;

    clrscr; writeln ('Nachalnoe vremya') ;

    writeln (Conv (ch1),':', Conv (mn1),':', Conv (sc1)) ;

    writeln ('vremy pribavlenia') ;

    writeln (Conv (chd),':', Conv (mnd),':', Conv (scd)) ;

    writeln ('konechnoe vremya') ;

    writeln (Conv (chr),':', Conv (mnr),':', Conv (scr)) ;

    readkey;

    end.
  2. 1 марта, 13:27
    0
    Var m, n, c, p, q, r: integer;

    begin

    read (m) ; write (':') ; read (n) ; write (':') ; read (c) ;

    write (' + ') ;

    read (p) ; write (':') ; read (q) ; write (':') ; read (r) ;

    write (' = ') ;

    c : = c + n * 60 + m * 60 * 60;

    r : = r + q * 60 + p * 60 * 60;

    r : = c + r;

    writeln (r div 3600 mod 24:2, ':', r mod 3600 div 60:2, ':', r mod 60:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Текущее показание электронных часов: m часов (0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислите сумму чисел от 1 до 100 т. е Для решения задачи используем соотношения:S=S+C; C=C=1, где S-текущее значение суммы чисел; С-текущее значение числа (начальное значение S=0 и C=1)
Ответы (2)
Дано количество секунд сначала суток. Вычислить текущее время в виде количества часов, минут и секунд.
Ответы (2)
Программа нужна на c# текущее время (часы, минуты, секунды) задано тремя переменными h, m, s. округлить его до целых значений минут и часов
Ответы (1)
Время на электронных часах записывается в виде двух чисел: часы (от 0 до 23) и минуты (от 0 до 59). Требуется написать программу, которая определяет, сколько раз на электронных часах за данный промежуток времени часы совпадали с минутами.
Ответы (1)
У исполнителя Вычислитель есть две команды, которым присвоены номера: 1-прибавь 2, 2-умножь на 3. Первая из них увеличивает текущее число на 2, вторая-умножает его на 3.
Ответы (1)