Задать вопрос
10 февраля, 05:40

Дано количество секунд сначала суток. Вычислить текущее время в виде количества часов, минут и секунд.

+1
Ответы (2)
  1. 10 февраля, 05:45
    0
    Uses crt;

    var a, h, m, s:integer;

    begin

    readln (a) ;

    h:=a div 3600;

    a:=a mod 3600;

    m:=a div 60;

    a:=a mod 60;

    s:=a;

    write (h,':', m,':', s) ;

    end.
  2. 10 февраля, 09:25
    0
    Var h, m, s, a: integer;

    begin

    readln (a) ;

    h: = a div 3600;

    m: = (a - h*3600) div 60;

    s: = a - m*60 - h*3600;

    writeln (h) ; writeln (m) ; write (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано количество секунд сначала суток. Вычислить текущее время в виде количества часов, минут и секунд. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд.
Ответы (1)
Написать программу к следующей задаче: Вводится с клавиатуры число, которое обозначает количество суток. Написать программу расчета количества часов, количества минут и количества секунд по заданному количеству суток.
Ответы (1)
Вычислите сумму чисел от 1 до 100 т. е Для решения задачи используем соотношения:S=S+C; C=C=1, где S-текущее значение суммы чисел; С-текущее значение числа (начальное значение S=0 и C=1)
Ответы (2)
1) Сначала суток прошло n секунд, определить: сколько полных часов прошло с начала суток, сколько полных минут прошло с начала текущего часа, сколько полных секунд прошло сначала текущей минуты.
Ответы (1)
Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.
Ответы (1)