Задать вопрос
1 марта, 14:05

Какое значение получит переменная у после выполнения фрагмента алгоритма?

х:=1

у:=2*х

у:=у+3

у:=у*х

у:=у+4

у:=у*х

у:=у+5

Восстановите формулу вычисления у для произвольного значения x

+2
Ответы (2)
  1. 1 марта, 14:54
    0
    1) x=1

    2) y=2*1=2

    3) y=2+3=5

    4) y=5*1=5

    5) y=5+4=9

    6) y=9*1=9

    7) y=9+5=14

    Ответ: 14

    y (x) = ((2*x+3) * x+4) * x+5
  2. 1 марта, 15:34
    -1
    Ответ: 14

    обоснование:

    Var x, y : Integer;

    Begin

    x:=1;

    y:=2*x;

    y:=y+3;

    y:=y*x;

    y:=y+4;

    y:=y*x;

    y:=y+5;

    Writeln (y) ;

    end.

    Общая формула вычисления: ((2*x+3) * x+4) * x+5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Какое значение получит переменная у после выполнения фрагмента алгоритма? х:=1 у:=2*х у:=у+3 у:=у*х у:=у+4 у:=у*х у:=у+5 Восстановите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
1) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 86; b: = a mod 10 + 14; a: = а div 3 * 5; 2) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 8673; b: = (a mod 100) * 10 + 14;
Ответы (1)
Помогите решить 1 написание блок-схему цикла для 2 дан линейный алгоритм а:=14; b:=8+a mod 6; a:=b*3 div 3 Чему равно значение переменных a и b после выполнения алгоритма 3 определите значение переменной после выполнения фрагмента алгоритма f:=
Ответы (1)