Задать вопрос
29 апреля, 01:53

С клавиатуры вводятся последовательно из k целых чисел вычислить произведение нечетных членов последовательности

+4
Ответы (1)
  1. 29 апреля, 04:41
    0
    Var I, K, P, x:integer;

    begin

    writeln ('введите количество чисел') ;

    readln (k) ;

    P:=1;

    for I:=1 to k do begin

    writeln ('введите число') ;

    readln (x) ;

    if (x mod 2) 0 then P:=P*x;

    end;

    writeln ('произведение нечётных членов = ', P) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся последовательно из k целых чисел вычислить произведение нечетных членов последовательности ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Помогите решить задачи в паскале: 3 9. Найти произведение целых нечетных чисел в промежутке [m, n], где m, n-произвольные вещественные числа (вводятся с клавиатуры). 10.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)