Задать вопрос
27 марта, 02:30

Дано натуральное число n. Получить новое число, поставив ноль перед каждой цифрой, кроме первой (например, дано число 567, результат - 50607) на паскале решить

+4
Ответы (1)
  1. 27 марта, 05:06
    0
    Uses crt;

    var a, h:longint;

    b:integer;

    begin

    clrscr;

    writeln ('Введи число') ;

    readln (a) ;

    h:=1;

    while a>0 do

    begin

    b:=a mod 10;

    h:=h*100+b;

    a:=a div 10;

    end;

    a:=0;

    while h>10 do

    begin

    b:=h mod 10;

    a:=a*10+b;

    h:=h div 10;

    end;

    writeln (a) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число n. Получить новое число, поставив ноль перед каждой цифрой, кроме первой (например, дано число 567, результат - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10 За цифрой 2 - только 5, 6, 8, 10, 11 За цифрой 3 - только 6, 7, 9, 11, 12 За
Ответы (1)
1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата.
Ответы (1)
Дано число. В этом числе необходимо изменить одну цифру таким образом, чтобы новое число делилось на 3 и было бы максимально возможным. В исходном числе нужно обязательно изменить одну цифру, даже если исходное число уже делилось на 3.
Ответы (1)
Нужно на C++ Дано число. В этом числе необходимо изменить одну цифру таким образом, чтобы новое число делилось на 3 и было бы максимально возможным. В исходном числе нужно обязательно изменить одну цифру, даже если исходное число уже делилось на 3.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)