Задать вопрос
27 марта, 00:38

Составьте программу, Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб).

Пример вывода:

10240 бит = 1280 байт = 1,25 Кб = 0,0012 Мб

+2
Ответы (1)
  1. 27 марта, 01:41
    0
    Var

    n:integer;

    begin

    read (n) ;

    write (n,' бит = ', n/8, ' байт = ', n/8192:0:2,' Кб = ', n / (8*sqr (1024)) : 0:4,' Мб') ;

    end.

    Альтернативное решение:

    var

    n: integer;

    b, kb, mb: real;

    begin

    read (n) ;

    b : = n / 8;

    kb : = b / 1024;

    mb : = kb / 1024;

    write (n, ' бит = ', b:0, ' байт = ', kb:0:2, ' Кб = ', mb:0:4, ' Мб') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб). Пример вывода: 10240 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу в паскале abc. Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб). Пример вывода: 10240 бит = 1280 байт = 1,25 Кб = 0,0012 Мб. Прошу помогите с формулами хотябы
Ответы (2)
1. Сколько байт информации содержит сообщение объемом 2 Кбит 2. Сколько байт информации сдержит 16 бит 3. Сколько байт информации содержит 1 Кб 4. Сколько Кбит информации содержит сообщение объемом 2048 бит 5.
Ответы (1)
1. заполните пропуски. 5 кбайт=_байт=_бит _кбайт=_байт=12288 бит _кбайт=байт=2 бит _гбайт=1536 мбайт=_кбайт 512 кбайт=2_байт=2_бит 2. перевидите 32 бит = ... байт 7 байт = ... бит 1,5 байта = ... бит 30 кб = ... байт 640,7 кб = ... байт 2035 байт = .
Ответы (1)
В каком варианте объёмы памяти расположены в порядке возрастания? 1) 5 бит, 3 байта, 20 бит, 1 Кбайт, 1010 байт 2) 5 бит, 3 байта, 20 бит, 1010 байт, 1 Кбайт 3) 5 бит, 20 бит, 3 байта, 1 Кбайт, 1010 байт 4) 5 бит, 20 бит, 3 байта, 1010 байт, 1 Кбайт
Ответы (1)
Вариант 1 1.3 Мбайт = ... Кбайт 2.1,5 Кбайт = ... байт 3.4096 бит = ... Кбайт = ... байт 4.5/128 Кбайт = ... байт = ... бит 5. 1/2 Кбайт 15 байт = ... байт 6.1024 бит + 2 байт = ... бит = ... байт
Ответы (1)