Задать вопрос
13 апреля, 08:50

Составьте программу в паскале abc. Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб).

Пример вывода:

10240 бит = 1280 байт = 1,25 Кб = 0,0012 Мб. Прошу помогите с формулами хотябы

+2
Ответы (2)
  1. 13 апреля, 10:06
    0
    Var

    b:real;

    begin

    Write ('Количество информации в битах ') ; Read (b) ;

    Write (b,' бит = ') ;

    b:=b/8; Write (b,' б = ') ;

    b:=b/1024; Write (b,' Кб = ') ;

    b:=b/1024; Write (b,' Мб = ') ;

    b:=b/1024; Write (b,' Гб = ') ;

    b:=b/1024; Write (b,' Тб')

    end.

    Пример

    Количество информации в битах 10240

    10240 бит = 1280 б = 1.25 Кб = 0.001220703125 Мб = 1.19209289550781E-06 Гб = 1.16415321826935E-09 Тб
  2. 13 апреля, 12:05
    0
    Var b:integer;

    begin

    write ('Введите количество бит: ') ;

    readln (b) ;

    write (b,' бит = ', b/8,' байт = ') ;

    writeln (b/8/1024,' Кбайт = ', b/8/1024/1024:6:4,' Мбайт') ;

    end.

    Пример:

    Введите количество бит: 10240

    10240 бит = 1280 байт = 1.25 Кбайт = 0.0012 Мбайт
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в паскале abc. Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб). Пример ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб). Пример вывода: 10240 бит = 1280 байт = 1,25 Кб = 0,0012 Мб
Ответы (1)
1. Сколько байт информации содержит сообщение объемом 2 Кбит 2. Сколько байт информации сдержит 16 бит 3. Сколько байт информации содержит 1 Кб 4. Сколько Кбит информации содержит сообщение объемом 2048 бит 5.
Ответы (1)
1. заполните пропуски. 5 кбайт=_байт=_бит _кбайт=_байт=12288 бит _кбайт=байт=2 бит _гбайт=1536 мбайт=_кбайт 512 кбайт=2_байт=2_бит 2. перевидите 32 бит = ... байт 7 байт = ... бит 1,5 байта = ... бит 30 кб = ... байт 640,7 кб = ... байт 2035 байт = .
Ответы (1)
В каком варианте объёмы памяти расположены в порядке возрастания? 1) 5 бит, 3 байта, 20 бит, 1 Кбайт, 1010 байт 2) 5 бит, 3 байта, 20 бит, 1010 байт, 1 Кбайт 3) 5 бит, 20 бит, 3 байта, 1 Кбайт, 1010 байт 4) 5 бит, 20 бит, 3 байта, 1010 байт, 1 Кбайт
Ответы (1)
Вариант 1 1.3 Мбайт = ... Кбайт 2.1,5 Кбайт = ... байт 3.4096 бит = ... Кбайт = ... байт 4.5/128 Кбайт = ... байт = ... бит 5. 1/2 Кбайт 15 байт = ... байт 6.1024 бит + 2 байт = ... бит = ... байт
Ответы (1)