Задать вопрос
12 мая, 03:04

Составьте программу которая заполняет массив а [1 ... 8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями

+4
Ответы (1)
  1. 12 мая, 06:39
    0
    Var

    a : array [1 ... 8] of integer;

    i, count, sum : integer;

    begin

    randomize;

    for i : = 1 to 8 do

    a[i] : = random (10) + 1;

    count : = 0; sum : = 0;

    for i : = 1 to 8 do

    if a[i] mod 2 = 0 then count : = count + 1

    else sum : = sum + a[i];

    writeln ('count = ', count) ;

    writeln ('sum = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая заполняет массив а [1 ... 8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
Составте пргорамму которая заполняет массив а 1.8 случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму массива с нечётнвми значениями
Ответы (1)