Задать вопрос
22 августа, 10:48

Составте пргорамму которая заполняет массив а 1.8 случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму массива с нечётнвми значениями

+1
Ответы (1)
  1. 22 августа, 14:05
    0
    Program dfg;

    var

    a: array [1 ... 8] of integer;

    f, n, i:integer;

    begin

    n:=0;

    randomize;

    for I:=1 to 8 do

    begin

    a[i]: = random (1,10) ;

    writeln (a[i]) ;

    if (a[i] mod 2) = 0 then

    begin

    f:=1;

    end

    else

    begin

    f:=0;

    end;

    n:=n+f;

    end;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте пргорамму которая заполняет массив а 1.8 случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
Составьте программу которая заполняет массив а [1 ... 8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями
Ответы (1)