Задать вопрос
24 марта, 18:24

Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные:

Входной поток содержит два целых числа N и K (1 < = N < = 10^100, 1 < = K < = 10^9) записанные в двух отдельных строках.

Выходные данные:

В выходной поток выведите остаток от деления N на K.

Пример входного файла (input. txt) : 239 16 Пример выходного файла (output. txt) : 15

+2
Ответы (1)
  1. 24 марта, 21:33
    0
    Program Task;

    Var t: Text;

    N, K, M: LongInt;

    Begin

    Assign (t, 'd:/input. txt') ;

    Reset (t) ;

    While Not EOF (t) Do

    Begin

    Read (t, N) ;

    Read (t, K) ;

    End;

    If (N Exp (100 * Ln (10))) Or (K Exp (9 * Ln (10))) Then

    WriteLn ('Input error!')

    Else

    Begin

    M : = N Mod K;

    Assign (t, 'd:/output. txt') ;

    Rewrite (t) ;

    Write (t, M) ;

    Close (t) ;

    Write ('Done.') ;

    End;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два целых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Даны два файла: input. txt и output. txt. В input. txt дана последовательность чисел: 1,6,11,16,21. В Output. txt отобразить размах ряда (т. е разность между наибольшим и наименьшим числом). Pascal
Ответы (1)
Найти сумму чисел в текстовом документе. Почему пишет неизвестный идентификатор. var a, b:integer; begin assign (input,'input. txt') ; reset (input) ; assign (output,'output.
Ответы (1)