Задать вопрос
7 сентября, 06:40

Напишите программу, которая вычисляет сумму первых n членов ряда. Значение n вводится с клавиатуры.

+3
Ответы (1)
  1. 7 сентября, 08:04
    0
    1)

    program gt;

    var s, n, a, i:integer;

    begin

    read (n)

    s:=0;

    randomize;

    for i:=1 to n do

    begin

    a:=random (100) ;

    s:=s+a;

    end;

    writeln (s) ;

    end.

    2)

    можно сделать с файлом

    assign ...

    reset ...

    rewrite ...

    while not eof ( ...) do

    begin

    read ( ..., a) ;

    s:=s+a;

    end;

    writeln ( ..., s) ;

    close ( ...)

    close ( ...) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая вычисляет сумму первых n членов ряда. Значение n вводится с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Написать программу, которая вычисляет сумму первых n членов ряда 1,3,5,7 ... Количество суммируемых членов ряда задаеться во время работы программы ...
Ответы (1)
Написать программу, которая вычисляет сумму n - первых членов ряда 1+1/2+1/3+1/4 + ... Количество суммируемых членов ряда задаётся во время работы программы.
Ответы (1)