Задать вопрос
15 ноября, 08:19

Составьте программу, которая заменяет все буквы "о" на символ "*" в строке s.

Использовать можно функции pos, length, copy, delete, insert.

+4
Ответы (1)
  1. 15 ноября, 11:21
    0
    Var s: string; i: integer;

    begin

    write ('Введите строку: ') ; read (s) ;

    for i:=1 to length (s) do

    if s[i]='о' then s[i]:='*';

    write ('Полученная строка: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая заменяет все буквы "о" на символ "*" в строке s. Использовать можно функции pos, length, copy, delete, insert. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Program mm; var o, oo, v, n, n1, q1, r1, y1:string; l, x, b, z, y, r, q:integer; begin v:='вычислить '; read (n) ; n1:=n; q:=pos (' + or - ', n) ; q1:=copy (n, 1, q-1) ; val (q1, x, r) ; Delete (n, 1, q) ; r:=pos (' - or + ', n) ;
Ответы (1)
Выберите правильный вариант ответа: Стандартные функции обработки строк? а) length (s) b) copy (a, n, k) c) delete (s, n, k) d) pos (s1, s2) e) insert (s1, s2, n)
Ответы (1)
Сделать из программы процедуру pascal Program kokokoko; uses crt; var fr, frn, s1:string; i:integer; begin clrscr; writeln ('Vvedite frazu:') ; readln (fr) ; fr:=fr+' '; While Pos (' ', fr) >0 do Begin s1:=Copy (fr, 1, Pos (' ', fr) - 1) ;
Ответы (1)
Дано слово "форматирование". Используя все возможные сначала функции, а потом процедуры получить как можно больше новых слов. Слова составляются на паскале с помощью функций copy, lenght и pos; и процедур delete, insert, str и val.
Ответы (1)
Определите результат выполнения фрагмента программы и запишите его в тетрадь А) а:="канатоходец" b:=copy (a, 3,2) + copy (a, 7,3) + copy (a, 1,2) writeln (b). Б) t:='компьютер' x:=copy (t, 1,4) + 'oc'+copy (t, 7,3) writeln (x)
Ответы (1)