Задать вопрос
9 июня, 02:06

1. Вводятся N оценок за четверть. Найдите среднюю оценку

2. Посчитать кол-во положительных чисел среди a, b, c

3. Найти кол-во ненулевых элементов в массиве A из N чисел

+5
Ответы (1)
  1. 9 июня, 05:05
    0
    1.

    var

    n, i, m:integer;

    x:real;

    begin

    write ('Число оценок: ') ;

    readln (n) ;

    for i:=1 to n do

    begin

    writeln ('Введите оценку: ') ;

    readln (m) ;

    x:=x+m

    end;

    x:=round (x/n) ;

    writeln ('Оценка за четверть ', x)

    end.

    2.

    var

    n:integer;

    a, b, c:real;

    begin

    write ('Число a: ') ;

    readln (a) ;

    if a>0 then n:=1;

    write ('Число b: ') ;

    readln (b) ;

    if b>0 then n:=n+1;

    write ('Число c: ') ;

    readln (c) ;

    if c>0 then n:=n+1;

    writeln ('Число положительных ', n)

    end.

    3.

    var

    n, i, s:integer;

    a:array of integer;

    begin

    write ('Размер массива: ') ;

    readln (n) ;

    SetLength (a, n) ;

    for i:=0 to n-1 do

    begin

    a[i]:=random (-3,3) ;

    write (a[i]:3) ;

    if a[i]0 then s:=s+1

    end;

    writeln;

    write ('Ненулевых элементов: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Вводятся N оценок за четверть. Найдите среднюю оценку 2. Посчитать кол-во положительных чисел среди a, b, c 3. Найти кол-во ненулевых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вася за 1 четверть получил по информатике 20 оценок. Чтобы вычислить какую оценку он получит необходимо найти среднее арифметическое этих оценок. Напишите программу для нахождения среднего арифметического оценок.
Ответы (1)
Среднюю оценку за четверть считают как частное от деления суммы всех оценок (С) на их количество (К) : С: К. Рассчитай среднюю оценку за четверть при следующих оценках: 4,5,4,3,4,4,5,4,3,4,5,3,4. 1) 3; 2) 4; 3) меньше 4; 4) больше 4
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Вова за день получил пять оценок. Вова хочет узнать свою самую лучшую и самую худшую оценку. Программа на вход получает 5 целых чисел - пять оценок. Оценка может принимать значение от 2 до 5. Программа выводит два числа - лучую и худшую оценку.
Ответы (1)