Задать вопрос
2 мая, 00:07

Решите в паскале)) даны координаты вершин прямоугольника А (X1, Y1), B (X2, Y2), C (X3, Y3), D (X4, Y4). Вычислите периметр и площадь прямоугольника.

+5
Ответы (2)
  1. 2 мая, 02:37
    0
    Var x1, x2, x3, x4, y1, y2, y3, y4:integer;

    AB, BC, p, s:real;

    begin

    read (x1, y1, x2, y2, x3, y3, x4, y4) ;

    AB:=sqrt (sqr (x1-x2) + sqr (y1-y2)) ;

    BC:=sqrt (sqr (x2-x3) + sqr (y2-y3)) ;

    p:=2 * (ab+bc) ;

    s:=ab*bc;

    write ('p=', p,' s=', s) ;

    end.
  2. 2 мая, 03:41
    0
    program umn;

    var X1, Y1, x2, y2, x3, y3, x4, y4, P, S, l1, l2:real;

    begin

    write ('Введите координаты вершин треугольника (A, B, C, D) : ') ; read (X1, Y1, x2, y2, x3, y3, x4, y4) ;

    l1 : = Sqrt (sqr (x2 - x1) + Sqr (y2-y1)) ;

    l2 : = Sqrt (sqr (x3 - x2) + Sqr (y3-y2)) ;

    S : = l1 * l2;

    P : = 2 * (l1+l2) ;

    write (S:3:2,' ', P:3:2) ;

    end.

    Если есть вопросы задавайте.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите в паскале)) даны координаты вершин прямоугольника А (X1, Y1), B (X2, Y2), C (X3, Y3), D (X4, Y4). Вычислите периметр и площадь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Прямоугольник. Зная координаты трех вершин прямоугольника на координатной плоскости, определить координаты четвертой вершины. Входные данные В одной строке записаны шесть чисел - координаты трех вершин прямоугольника.
Ответы (1)
Даны координаты трех вершин треугольника. Найти его площадь. Пример. Для вершин (0.0) ; (0,1) ; (1,0) площадь - 0,5.
Ответы (1)
Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет. (На Паскале) Входные данные Вводятся 4 числа: координаты первой точки (x1, y1) и координаты второй точки (x2, y2).
Ответы (1)
Даны координаты двух противоположных вершин прямоугольника: (x1, y1), (x2, y2). Стороны прямоугольника параллельны осям координат. Найти периметр и площадь данного прямоугольника.
Ответы (1)
Даны координаты двух противоположных вершин прямоугольника: (x1, y1), (x2, y2). Стороны прямоугольника параллельны осям координат. Найти периметр и площадь прямоугольника.
Ответы (1)