Задать вопрос
13 сентября, 08:22

Даны координаты двух противоположных вершин прямоугольника: (x1, y1), (x2, y2). Стороны прямоугольника параллельны осям координат. Найти периметр и площадь прямоугольника.

+4
Ответы (1)
  1. 13 сентября, 10:12
    0
    Program pryamougolnik;

    var x1, x2, y1, y2, a, b, s, p:real;

    begin

    write ('Введите координату х1 = ') ;

    readln (x1) ;

    write ('Введите координату y1 = ') ;

    readln (y1) ;

    write ('Введите координату х2 = ') ;

    readln (x2) ;

    write ('Введите координату y2 = ') ;

    readln (y2) ;

    a:=abs (x2-x1) ;

    b:=abs (y2-y1) ;

    p: = (a+b) * 2;

    s:=a*b;

    writeln ('Периметр прямоугольника P = ', p) ;

    writeln ('Площадь прямоугольника S = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны координаты двух противоположных вершин прямоугольника: (x1, y1), (x2, y2). Стороны прямоугольника параллельны осям координат. Найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны координаты двух противоположных вершин прямоугольника: (x1, y1), (x2, y2). Стороны прямоугольника параллельны осям координат. Найти периметр и площадь данного прямоугольника.
Ответы (1)
Составьте программу для вычисления периметра и площади прямоугольника, если известны координаты противоположных вершин прямоугольника (x1, x2) и (y1, y2). Стороны прямоугольника параллельны осям координат.
Ответы (1)
1) Стороны прямоугольника параллельны осям координат. Одна из вершин имеет координаты (0,0), координаты противоположной вершины задаются с клавиатуры. Вычислите площадь прямоугольника. 2) С клавиатуры вводится натуральное число.
Ответы (1)
Даны координаты противопложных вершин прямоугольника х1 у1 х2 у2 стороны прямоугольника парралельны осям координата координат * составьте программу вычесления периметра и площади прямоугольника
Ответы (1)
Прямоугольник. Зная координаты трех вершин прямоугольника на координатной плоскости, определить координаты четвертой вершины. Входные данные В одной строке записаны шесть чисел - координаты трех вершин прямоугольника.
Ответы (1)