Задать вопрос
15 ноября, 05:35

дано натуральное число n и последовательность из n натуральных чисел. написать программу определяющую количество положительных членов в последовательности

+2
Ответы (1)
  1. 15 ноября, 06:20
    0
    Pascal

    var

    mas:array[1 ... 100] of integer;

    sum, n, i:integer;

    begin

    readln (n) ;

    sum:=0;

    for i:=1 to n do

    readln (mas[i]) ;

    for i:=1 to n do

    if mas[i]>0 then

    sum:=sum+1;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дано натуральное число n и последовательность из n натуральных чисел. написать программу определяющую количество положительных членов в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Дано натуральное n и последовательность чисел x1, x2, ..., xn. Вычислить среднее арифметическое членов последовательности. В первой строке содержится целое число n (1≤n≤100) - количество членов последовательности.
Ответы (1)
Дана последовательность целых чисел. Прищнак окончания ввода - число 0 (элементом последовательности не считается). В последовательности как минимум одно число. Написать программу, определяющую, является ли последовательность чисел возрастающей.
Ответы (1)
1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)