Задать вопрос
4 декабря, 02:35

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.

2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

+3
Ответы (1)
  1. 4 декабря, 02:55
    0
    1

    var

    i, k:integer;

    a, b:array[1 ... 10]of integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (-10,10) ;

    write (a[i]:3)

    end;

    for i:=1 to 10 do

    begin

    if a[i]<0 then

    begin

    k:=k+1;

    b[k]:=a[i]

    end

    end;

    for i:=1 to 10 do

    begin

    if a[i]>=0 then

    begin

    k:=k+1;

    b[k]:=a[i]

    end

    end;

    writeln;

    writeln ('Преобразованный массив:') ;

    for i:=1 to 10 do write (b[i]:3)

    end.

    2.

    var i, j, k, n, x, p:integer;

    a, b:array of integer;

    f:boolean;

    begin

    write ('Сколько будет чисел: ') ;

    readln (n) ;

    SetLength (a, n) ;

    for i:=1 to n do

    begin

    f:=false;

    write ('Введите число: ') ;

    readln (x) ;

    for j:=0 to n-1 do

    if x=a[j] then f:=true;

    if f=false then

    begin

    a[k]:=x;

    k:=k+1;

    end

    end;

    SetLength (b, k) ;

    for i:=0 to k-1 do b[i]:=a[i];

    for i: = 0 to k-1 do

    for j : = 0 to k-1 do

    begin

    if b[i] < b[j] then

    begin

    p : = b[i];

    b[i] : = b[j];

    b[j] : = p

    end

    end;

    writeln ('Отсортированный массив:') ;

    for i:=0 to k-1 do write (b[i]:3)

    end.

    2.1

    var

    i, j, k, n, x, p:integer;

    a:array[1 ... 1000] of integer;

    f:boolean;

    begin

    write ('Сколько будет чисел: ') ;

    readln (n) ;

    k:=1;

    for i:=1 to n do

    begin

    f:=false;

    write ('Введите число: ') ;

    readln (x) ;

    for j:=1 to n do

    if x=a[j] then f:=true;

    if f=false then

    begin

    a[k]:=x;

    k:=k+1;

    end

    end;

    for i:=1 to k-1 do

    for j:=1 to k-1 do

    begin

    if a[i] < a[j] then

    begin

    p: = a[i];

    a[i]: = a[j];

    a[j]: = p

    end

    end;

    writeln ('Отсортированный массив:') ;

    for i:=1 to k-1 do write (a[i]:3)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи с помощью Паскаля: 1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)