Задать вопрос
3 декабря, 18:13

Вводится строка (до пробела)

Необходимо определить является ли она палиндромом или нет.

Вывести - YES или NO

+2
Ответы (1)
  1. 3 декабря, 20:27
    0
    Примечание: ввод слова с маленькой буквы.

    #include

    #include

    using namespace std;

    int main ()

    {

    setlocale (LC_ALL, "Russian") ;

    string s;

    cin >> s;

    bool res = true;

    for (int i = 0; i < s. length () / 2; i++)

    if (s[i]! = s[s. length () - i - 1]) {

    res = false;

    break;

    }

    if (res) cout << "YES/n";

    else cout << "NO/n";

    system ("pause") ;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится строка (до пробела) Необходимо определить является ли она палиндромом или нет. Вывести - YES или NO ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом? Палиндромами называются числа, которые читаются одинаково слева-направо и справа-налево. Напрмер, 8998, 3333. Вводится целое число N (999 < N
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)