Задать вопрос
20 октября, 14:44

1.

В массиве d1, d2, ..., d30 найти

произведение чисел, исключая первый и последний элемент.

+2
Ответы (1)
  1. 20 октября, 16:44
    0
    Uses crt;

    var a:array[1 ... 30] of integer;

    k, i:integer;

    begin

    randomize;

    for i:=1 to 30 do begin

    a[i]:=random (10) + 1;

    write (a[i]:3) ;

    end;

    k:=1;

    for i:=2 to 29 do

    k:=k*a[i];

    writeln;

    write (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. В массиве d1, d2, ..., d30 найти произведение чисел, исключая первый и последний элемент. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить сумму и разность двух одномерных массивов содержащих 20 элементов. В массиве суммы найти максимальный элемент и его индекс. В массиве разности найти минимальный элемент и его индекс. Исходные массивы ввести при помощи случайных чисел.
Ответы (1)
Массив a[1 ... 10] заполните случайными целыми числами в диапазоне от 1 до 10. Определите, есть ли в массиве элемент, равный 5. Ответ выведите в виде слов "Да" или "Нет".
Ответы (1)
Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не повторяется. Входные данные Первая строка содержит размер массива N.
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)
2. В массиве Z[1 ... N] определить сумму нечетных чисел от последнего нулевого значения до Z[N] и среднее арифметическое четных чисел, находящихся в массиве до последнего нуля. Если нулей в массиве нет, то рассортировать все числа по убыванию.
Ответы (1)