Задать вопрос
1 мая, 04:05

1. Дан массив из 12 натуральных чисел. определить сумму 6 первых элементов массива.

2. Дан массив из 10 натуральных чисел. Определить количество элементов равных контрольному числу 7.

+2
Ответы (1)
  1. 1 мая, 04:51
    0
    1)

    program chik;

    const n=12;

    var i, s:integer;

    a:array[1 ... 12]of integer;

    begin

    s:=0;

    for i:=1 to n do

    begin

    read (a[i]) ;

    if (i<7) then s:=s+a[i];

    end;

    writeln (s) ;

    end.

    2)

    program chik;

    const n=10;

    var i, s:integer;

    a:array[1 ... 12]of integer;

    begin

    s:=0;

    for i:=1 to n do

    begin

    read (a[i]) ;

    if (a[i]=7) then s:=s+1;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дан массив из 12 натуральных чисел. определить сумму 6 первых элементов массива. 2. Дан массив из 10 натуральных чисел. Определить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)