Задать вопрос
22 октября, 07:10

Напишите программу на Паскале. Дан целочисленный квадратный массив 10x10. Найти сумму максимальных элементов из каждой строки. Предпологается, что в каждой строке такой элемент единственный

+3
Ответы (1)
  1. 22 октября, 08:39
    0
    var

    a : array [1 ... 10] of longint;

    i, j, max, ans : longint;

    begin

    for i:=1 to 10 do

    begin

    max:=-maxlongint;

    for j:=1 to 10 do

    begin

    read (a[i]) ;

    if a[i]>max then max:=a[i];

    end;

    ans:=ans+max;

    writeln;

    end;

    writeln (ans) ;

    end.

    И этот массив не квадратный. Такие массивы называют двумерными массивами.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на Паскале. Дан целочисленный квадратный массив 10x10. Найти сумму максимальных элементов из каждой строки. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Дан целочисленный прямоугольный массив 6x10. Опишите в программе "ПаскальАВС" алгоритм вычисления суммы минимальных элементов из каждой строки. Напечатать значение этой суммы. Предполагается, что в каждой строке минимальный элемент единственный.
Ответы (1)