Задать вопрос
6 января, 10:48

Напишите программу на Паскале. Для заданных чисел X и N вычислите Z=X^N=X*X ... X.

X*X ... X=N

+2
Ответы (1)
  1. 6 января, 12:40
    0
    var

    x, n, x1 : real;

    begin

    readln (x, n) ;

    x1:=abs (x) ;

    if x<0 then writeln (-1*exp (n*ln (x1)) : 0:0)

    else writeln (exp (n*ln (x)) : 0:0) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на Паскале. Для заданных чисел X и N вычислите Z=X^N=X*X ... X. X*X ... X=N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите решить задачи на цикл с параметром. Решения оформить как в Паскале. 1) задать 5 чисел. найти среднюю сумму положительных чисел, произведение чисел, некратных 12 и количество четных чисел среди заданных 2) В фирме работают 5 сотрудников.
Ответы (1)
Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)