Задать вопрос
8 июля, 05:38

Дан массив целых чисел. Выяснить:

1) верно ли, что сумма массива есть честное число;

2) верно ли, что сумма квадратов элементов массива есть пятизначное число.

+3
Ответы (1)
  1. 8 июля, 07:22
    0
    Uses crt;

    var

    i, sum, kvad:integer;

    mas:array [1 ... 10] of integer;

    begin

    for i:=1 to 10 do

    mas[i]:=random (100) ;

    for i:=1 to 10 do

    write (mas[i],' ') ;

    for i:=1 to 10 do

    sum:=sum+mas[i];

    if sum mod 2=0 then

    writeln ('sum=', sum,' summa 4etna9')

    else

    writeln ('sum=', sum,' summa ne 4etna9') ;

    for i:=1 to 10 do

    kvad:=kvad+mas[i]*mas[i];

    if kvad>9999 then

    writeln ('kvad=', kvad,' p9tizna4noe')

    else

    writeln ('kvad=', kvad,' ne p9tizna4noe') ;

    read;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел. Выяснить: 1) верно ли, что сумма массива есть честное число; 2) верно ли, что сумма квадратов элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)