Задать вопрос
30 марта, 21:04

1. Дана вещественная матрица размерности n * m. Удалить k столбец матрицы.

+5
Ответы (2)
  1. 30 марта, 21:24
    0
    Не указан язык. пример на псевдоязыке. Вариант 4

    Массив А (м, н)

    Массив Б (м, н-1)

    Сформировать (А, Б) ; / / Это процедура которая как-то формирует исходные массивы

    Прочитать (к) ; / / Это процедура, которая откуда-то берёт к и проверяет его на корректность

    Для стр=1 по м Цикл

    Для стлб=1 по к-1 Цикл

    Б (стр, стлб) = А (стр, стлб) ;

    КонецЦикла;

    Для стлб=к+1 по н Цикл

    Б (стр, стлб-1) = А (стр, стлб) ;

    КонецЦикла;

    КонецЦикла;

    Ну где-то так
  2. 31 марта, 00:12
    0
    У меня работа с одним массивом.

    Паскаль.

    ---

    uses crt;

    const N=4;

    M=6;

    var a: array [1 ... n, 1 ... m] of integer;

    x, y, k, p: integer;

    begin

    for x:=1 to n do begin

    for y:=1 to m do begin

    a[x, y]:=random (21) - 10;

    write (a[x, y]:4) ;

    end;

    writeln;

    end;

    write ('k=') ; readln (k) ;

    if k<=m then p:=m-1 else p:=m;

    for y:=k+1 to m do

    for x:=1 to n do

    a[x, y-1]:=a[x, y];

    for x:=1 to n do begin

    for y:=1 to p do

    write (a[x, y]:4) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дана вещественная матрица размерности n * m. Удалить k столбец матрицы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.
Ответы (1)
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
ПаскальАВС. №1. Вычислить сумму и число положительных элементов матрица А[N, N], находящихся над главной диагональю. №2. Дана вещественная матрица А размера n x m.
Ответы (1)