Задать вопрос
31 декабря, 12:44

Паскаль! напишите програму, которая формирует массив из N элементов (максимальное количество ровно 20), значения элементов массива - случайные числа от-10 до 25.

Программа должна:

1) выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечетных местах.

2) вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5.

3) найти минимальное значение и максимальное значение элементов масива.

+5
Ответы (1)
  1. 31 декабря, 14:59
    0
    Var

    a:array[1 ... 20] of integer;

    i, n, min, max, s:integer;

    begin

    randomize;

    s:=0;

    writeln ('Введи кол-во элементов в массиве') ;

    readln (n) ;

    for i:=1 to n do

    a[i]:=random (35) - 10;

    for i:=1 to n do

    if i mod 2 = 0 then writeln ('a[', i,']=', a[i]) ;

    for i:=1 to n do

    if i mod 2 >0 then writeln ('a[', i,']=', a[i]) ;

    for i:=1 to n do if (a[i] mod 3 = 0) or (a[i] mod 5 = 0) then s:=s+a[i];

    writeln ('Сумма членов кратных 3 или 5 = ', s) ;

    min:=a[1];

    max:=a[1];

    for i:=2 to n do begin

    if a[i]
    if a[i]>max then max:=a[i];

    end;

    writeln ('Максимум=', max) ;

    writeln ('Минимум=', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! напишите програму, которая формирует массив из N элементов (максимальное количество ровно 20), значения элементов массива - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)