Задать вопрос
23 апреля, 11:48

Ввести с клавиатуры двузначное целое число и определить какая из его цифр больше. (Ответ "Первая цифра","Вторая цифра" или "Равны").

+3
Ответы (1)
  1. 23 апреля, 14:43
    0
    Program Task;

    Var a, b, c: Integer;

    Begin

    Write ('a = ') ;

    ReadLn (a) ;

    If (a 99) Then

    WriteLn ('Число не двузначное')

    Else

    Begin

    b : = a Div 10;

    c : = a - (b * 10) ;

    If b > c Then

    WriteLn ('Первая цифра')

    Else if b < c Then

    WriteLn ('Вторая цифра')

    Else

    WriteLn ('Равны')

    End;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры двузначное целое число и определить какая из его цифр больше. (Ответ "Первая цифра","Вторая цифра" или "Равны"). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе задание дано целое трёхзначное число x.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Напишите программы в Pascal: 1. Ввести целое число и определить, верно ли, что все его цифры расположены в порядке возрастания ... 2. Ввести целое число и "перевернуть" его, так чтобы первая цифра стала последней и т. д.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)