Задать вопрос
8 июля, 21:27

Дан массив а 5. Случайные числа от 0 до 30. Найти сумму и среднее арифметическое всех чисел.

+5
Ответы (1)
  1. 8 июля, 23:05
    0
    Program z1;

    var a:array [1 ... 5] of integer;

    s, k, n : integer;

    begin

    for I:=1 to 5 do begin

    readln (a[I]) ;

    s:=s+a[I];

    k:=k+1;

    end;

    n:=s/k;

    writeln (s, k) ;

    end.

    надеюсь помог
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив а 5. Случайные числа от 0 до 30. Найти сумму и среднее арифметическое всех чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Умышленные угрозы подразделяются на: 1) случайные и пассивные 2) случайные, пассивные и активные 3) случайные и активные 4) пассивные и активные 5) случайные и непреднамеренные
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)