Задать вопрос
29 сентября, 01:15

Написать программу для нахождения а) НОД, б) НОК двух натуральных чисел а, b.

+2
Ответы (1)
  1. 29 сентября, 01:47
    0
    Program gt1;

    var m, n, q, r, t:longint;

    begin

    read (m, n) ;

    t:=m*n;

    r:=1;

    while r0 do

    begin

    q:=m div n;

    r:=m mod n;

    if (r0) then begin

    m:=n;

    n:=r;

    end;

    end;

    t:=t div n;

    write (n,' ', t) ;

    end.

    t-НОК

    n-получившиеся НОД
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для нахождения а) НОД, б) НОК двух натуральных чисел а, b. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы