Задать вопрос
29 июля, 00:49

Вводится последовательность натуральных чисел. Ноль - при-знак конца. Подсчитайте, сколько раз в этой последовательности встре-чается максимальное число, и выдайте полученный результат.

+2
Ответы (1)
  1. 29 июля, 01:18
    0
    Program gt;

    var a, max, s:longint;

    begin

    a:=-1;

    max:=-100;

    s:=0;

    while a0 do

    begin

    read (a) ;

    if (a=max) then s:=s+1;

    if (a>max) then begin

    max:=a;

    s:=1;

    end;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится последовательность натуральных чисел. Ноль - при-знак конца. Подсчитайте, сколько раз в этой последовательности встре-чается ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Вводится последовательность натуральных чисел, не превосхо-дящих 20000. Ноль - признак конца. Требуется вывести максимальное из произведений двух элементов последовательности, которое делится на 26.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
помогите решить. Всё в с++, для code blocks. 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)