Задать вопрос
17 октября, 16:30

Вводится последовательность натуральных чисел, не превосхо-дящих 20000. Ноль - признак конца. Требуется вывести максимальное из произведений двух элементов последовательности, которое делится на 26.

+1
Ответы (1)
  1. 17 октября, 17:47
    0
    Программа на паскале:

    const

    MAX_N = 20001;

    var

    a: array[1 ... MAX_N] of integer;

    n, i, j, p, maxp: integer;

    begin

    i : = 1;

    read (a[i]) ;

    while a[i] 0 do

    begin

    inc (i) ;

    read (a[i]) ;

    end;

    n : = i - 1;

    maxp : = 0;

    for i : = 1 to n do

    for j : = 1 to n do

    begin

    p : = a[i] * a[j];

    if (p mod 26 = 0) and (p > maxp) then

    maxp : = p;

    end;

    if maxp = 0 then writeln ('Not found')

    else writeln (maxp) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится последовательность натуральных чисел, не превосхо-дящих 20000. Ноль - признак конца. Требуется вывести максимальное из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Вводится последовательность натуральных чисел - рост учеников класса, не превосходящих 30. Ноль - признак конца. Требуется вывести рост двух самых высоких учеников
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)