Задать вопрос
28 декабря, 20:25

Вводится последовательность натуральных чисел - рост учеников класса, не превосходящих 30. Ноль - признак конца. Требуется вывести рост двух самых высоких учеников

+4
Ответы (1)
  1. 28 декабря, 21:02
    0
    Должно работать:

    program prim;

    var a: array[0 ... 99999] of integer;

    i:byte;

    f:integer;

    b, c:integer;

    begin

    for i:=0 to 99999 do begin

    readln (a[i]) ;

    if a[i]=0 then break;

    f:=i;

    end;

    for i:=0 to f do begin

    if a[i]>c then begin

    if a[i]>b then b:=a[i] else c:=a[i];

    end; end;

    writeln (b, ' ', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится последовательность натуральных чисел - рост учеников класса, не превосходящих 30. Ноль - признак конца. Требуется вывести рост ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Вводится последовательность натуральных чисел, не превосхо-дящих 20000. Ноль - признак конца. Требуется вывести максимальное из произведений двух элементов последовательности, которое делится на 26.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)