Задать вопрос
13 августа, 13:10

найти среднее арифметическое четных чисел из промежутка от 1 до 10

+3
Ответы (2)
  1. 13 августа, 13:50
    0
    Program vtkbox479; Название программы

    var i, s:integer; Объявление переменных

    begin Начало программы

    for i:=1 to 10 do Цикл от 1 до 10

    s:=s+i; Сумме присваиваем значение сумма + число i

    writeln (s/i) ; Выводим сумма деленная на число i

    end. Конец программы

    П. с. расписал, с тебя лучший ответ.
  2. 13 августа, 17:09
    0
    Var s, i: integer;

    Begin

    s : = 0;

    For i : = 1 To 10 Do

    If i Mod 2 = 0 Then s : = s + i;

    Writeln ('Сумма четных чисел: ', s) ;

    Writeln ('Ср. арифметическое: ', s/5) ;

    End.

    Решение:

    for i:=1 To 10 Do {цикл}

    Определяем четные числа командой i Mod 2 = 0.

    Если числа четные, то они складываются и делятся на 5, так как в промежутке от 1 до 10 всего пять четных чисел.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти среднее арифметическое четных чисел из промежутка от 1 до 10 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вводятся числа с клав-ы до 0 в программе находится минимальное из чисел, кол-во четных и среднее арифметическое четных. помогите переделать программу для нахождения кол-ва чисел кратных 5 и максимальное из чисел
Ответы (1)
2. Протабулируйте функцию у = xsin2x на промежутке [-2; 2] с шагом 0,2 и вычислите среднее арифметическое отрицательных значений. 3. Найти все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10. 4.
Ответы (1)
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)
1. Найти среднее арифметическое двузначных чисел кратных 7 2. Найти среднее арифметическое первых 10 чисел делящихся на 5 (в паскале)
Ответы (1)
найти сумму нечётных чисел, из промежутка от 11 до 99, найти среднее арифметическое чисел от 1 до 50
Ответы (1)