Задать вопрос
21 мая, 04:07

найти сумму нечётных чисел, из промежутка от 11 до 99, найти среднее арифметическое чисел от 1 до 50

+1
Ответы (1)
  1. 21 мая, 06:13
    0
    uses crt;

    var s, i:integer;

    begin

    for i:=11 to 99 do

    if a mod 2 0 then s:=s+i;

    writeln (s) ;

    readln;

    end.

    2.

    uses crt;

    var s, i:integer;

    begin

    for i:=1 to 50 do s:=s+i;

    writeln (s/50) ;

    readln;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти сумму нечётных чисел, из промежутка от 11 до 99, найти среднее арифметическое чисел от 1 до 50 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет: а) среднее арифметическое нечётных чисел б) сумму чисел, не превышающих 10 в) сумму чисел кратных 3 На экран выводятся исходные значения и результаты
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
2. Протабулируйте функцию у = xsin2x на промежутке [-2; 2] с шагом 0,2 и вычислите среднее арифметическое отрицательных значений. 3. Найти все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10. 4.
Ответы (1)