Задать вопрос
15 февраля, 03:28

1.

Написать

программу для решения задачи: Точки на плоскости

заданы своими координатами. Определить какая из них находится ближе к началу

координат.

+3
Ответы (1)
  1. 15 февраля, 05:47
    0
    Uses crt;

    var n, minind, i:integer;

    min, x, y:real;

    begin

    writeln ('Введите количество точек: ') ;

    read (n) ;

    writeln ('Вводите по очереди координаты x и y точек.') ;

    read (x, y) ;

    min:=sqr (x) + sqr (y) ;

    minind:=1;

    for i:=2 to n do

    begin

    read (x, y) ;

    if sqr (x) + sqr (y)
    begin

    min:=sqr (x) + sqr (y) ;

    minind:=i;

    end;

    end;

    writeln ('Точка под номером ', minind,'.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Написать программу для решения задачи: Точки на плоскости заданы своими координатами. Определить какая из них находится ближе к началу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! На плоскости заданы три точки своими координатами. Определить расстояние от точек до начала координат и напечатать, какая из точек расположена ближе к началу координат. (с повтором)
Ответы (1)
Три точки А (х₁; у₁), В (х₂; у₂), С (х₃; у₃) задаются своими координатами. Написать программу, которая определяет, какая из этих точек ближе к началу координат.
Ответы (1)
Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.
Ответы (1)
Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)