Задать вопрос
9 апреля, 04:38

Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.

+1
Ответы (1)
  1. 9 апреля, 06:09
    0
    может быть так:

    var x1, x2, y1, y2:integer;

    a, b:real;

    begin

    write ('Введите x1 и x2: ') ;

    readln (x1, x2) ;

    write ('Введите y1 и y2: ') ;

    readln (y1, y2) ;

    a:=sqrt (sqr (x1) + sqr (y1)) ;

    b:=sqrt (sqr (x2) + sqr (y2)) ;

    if a>b then writeln ('1-я точка ближе')

    else writeln ('2-я точка ближе') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Паскаль! На плоскости заданы три точки своими координатами. Определить расстояние от точек до начала координат и напечатать, какая из точек расположена ближе к началу координат. (с повтором)
Ответы (1)
Даны координаты двух точек A (x1, y2) и B (x2, y2) в прямоугольной системе координат. Какая из этих двух точек находится дальше от начала координат?
Ответы (1)
1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)