Задать вопрос
13 апреля, 21:26

В паскале!

Известно,

что Покупатель приобрел а кг яблок по цене в руб. и с кг груш по цене d руб.

Покупатель имеет S рублей. Напишите программу, которая определяет, хватит ли у

покупателя средств на данную покупку?

+1
Ответы (2)
  1. 13 апреля, 22:06
    0
    Program one;

    var s, a, b, c, d, m:real;

    begin

    writeln ('Введите цену яблок, груш ') ;

    readln (s, a) ;

    writeln ('Введите кол-во яблок, груш в кг ') ;

    readln (b, c) ;

    m: = (a*b) + (c*d) ;

    if s > = m then writeln ('Денег хватит', m)

    else

    writeln ('Денег не хватит') ;

    end.
  2. 13 апреля, 23:49
    0
    Program cena;

    uses crt;

    var

    s, a, b, c, d, su:real;

    begin

    clrscr;

    writeln ('Cymma kotopaya ectb y pokypatelya: ') ;

    read (s) ;

    writeln ('Ckolko priobel yablock (kg) : ') ;

    read (a) ;

    writeln ('Cena yablock:') ;

    read (b) ;

    writeln ('Ckolko priobrel grush (kg) : ') ;

    read (c) ;

    writeln ('Cena grush: ') ;

    read (d) ;

    su: = (a*b) + (c*d) ;

    if s > = su then writeln ('dannoy summu hvatit dlya etoy pokypki, vsego za pokupku ', su)

    else

    writeln ('Etoy symmu ne hvatit dlya pokupki') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В паскале! Известно, что Покупатель приобрел а кг яблок по цене в руб. и с кг груш по цене d руб. Покупатель имеет S рублей. Напишите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
У прилавка магазина выстроилась очередь из N покупателей. Время обслуживания i-го покупателя равно ti. Определить время Ci пребывания i-го покупателя в очереди. Протестировать программу на следующих исходных данных: а) Номер покупателя - 5.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
В Паскале: 1. Составить функцию и процедуру, которая определяет сумму всех чисел от 1 до N. 2. Составить программу, которая определяет НОД и НОК двух чисел.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)