Задать вопрос
15 августа, 05:41

Решить программу с помощью циклов while и repeat.

Посчитать сумму чисел больше 20, но меньше 100, кратное 3.

+4
Ответы (1)
  1. 15 августа, 09:05
    0
    Var summ, i: integer;

    begin

    summ:=0;

    for i:=21 to 99 do if (i mod 3) = 0 then summ:=summ+i;

    write ('сумма чисел кратных трём = ', summ) ;

    end.

    var summ, i: integer;

    begin

    i:=21;

    sum:=0;

    while (i<100) do begin

    if (i mod 3) = 0 then summ:=summ+i;

    i:=i+1;

    end;

    write ('сумма чисел кратных трём = ', summ) ;

    end.

    var summ, i: integer;

    begin

    i:=21;

    summ:=0;

    repeat

    if (i mod 3) = 0 then summ:=summ+i;

    i:=i+1;

    until (i>=100) ;

    write ('сумма чисел кратных трём = ', summ) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить программу с помощью циклов while и repeat. Посчитать сумму чисел больше 20, но меньше 100, кратное 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)
Реализовать с помощью 3-х циклов: while, repeat, for) Составить программу, которая выдавала бы сообщение ' true ', если последовательность из N целых чисел, вводимых с клавиатуры, является возрастающей
Ответы (1)
Натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя, является ли число м совершенным? Напиши программу в паскале циклов while или repeat
Ответы (1)
Определить значение переменной у после выполнения следующих фрагментов программы: a) Var у : real; i : integer; у : = 1; i : = 5; while i> 2 do i: = i - 1; y:=y + 1 * i; b) Var у : real; i : integer; у : = 1; i : = 2; repeat i: = 2 * i;
Ответы (1)
Помогите Найти и объяснить ошибки п/п Пример Ответ Пояснения 1 for i=1 to n do; 2 for i:=n to 1 do 3 for i=1 to n do step 1 4 while a < 5 do; a:=a+1; b:=b+a; 5 Repeat a < 5 a:=a+1; b:=b+a; until; 6 while c < k or k = 0 do 7 while c < k s:=s+k;;
Ответы (1)