Задать вопрос
19 ноября, 14:56

Дана последовательность из n целых чисел. Найти произведение индексов простых чисел. Программа на Паскаль.

+2
Ответы (1)
  1. 19 ноября, 15:59
    0
    uses crt;

    var n, t, i, j, mult:integer;

    flag:byte;

    begin

    writeln ('Input "n" and elements of array: ') ;

    read (n) ;

    mult:=1;

    for i:=1 to n do

    begin

    flag:=1;

    read (t) ;

    if t mod 2 = 0 then

    begin

    j:=3;

    while j
    begin

    if t mod j = 0 then

    begin

    flag:=0;

    break;

    end;

    inc (j, 2) ;

    end;

    end;

    if flag=1 then

    mult:=mult*i;

    end;

    writeln (mult) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность из n целых чисел. Найти произведение индексов простых чисел. Программа на Паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна содержаться сумма индексов.
Ответы (1)
Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)