Задать вопрос
5 июня, 17:36

среди четырёхзначных чисел найти все числа сумма цифр, которых кратно 3 и больше 15

+3
Ответы (1)
  1. 5 июня, 18:12
    0
    uses crt;

    var i, s:integer;

    begin

    for i:=1000 to 9999 do

    begin

    s:=strtoint (inttostr (i) [1]) + strtoint (inttostr (i) [2]) + strtoint (inttostr (i) [3]) + strtoint (inttostr (i) [4]) ;

    if (s>15) and (s mod 3=0) then

    write (i,' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «среди четырёхзначных чисел найти все числа сумма цифр, которых кратно 3 и больше 15 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход два двузначных десятичных числа. По полученным числам строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма цифр первого числа и сумма цифр второго числа. 2.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Решить в паскале: дано двузначное число, определить: а) кратно ли 3 сумма его цифр; б) кратно ли сумма его цифр числу a
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Напишите на паскале (АВС). Задание: Среди всех четырехзначных натуральных чисел вывести на экран "особо счастливые", у которых сумма цифр в четных разрядах равна сумме цифр в нечетных.
Ответы (1)