Задать вопрос
3 мая, 02:46

Дан целочисленный массив размера K. Вычислить количество положительных и количество отрицательных элементов массива.

+2
Ответы (1)
  1. 3 мая, 03:15
    0
    Uses crt;

    var mas: array [1 ... 1000] of real;

    x, k, o, p:integer;

    begin

    write ('K=') ; readln (K) ;

    o:=0; p:=0;

    for x:=1 to K do

    begin

    write ('mas[', x,']:') ;

    readln (mas[x]) ;

    if mas[x]<0 then inc (o) ;

    if mas[x]>0 then inc (p) ;

    end;

    writeln;

    writeln ('Отрицательных элементов: ', o) ;

    writeln ('Положительных элементов: ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив размера K. Вычислить количество положительных и количество отрицательных элементов массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)