Задать вопрос
29 января, 02:24

Помогите составить программу для PascalABC, которая выводит слово, введённое с клавиатуры, с буквами в обратном порядке и сохраняет результат в оперативную память

+1
Ответы (1)
  1. 29 января, 03:05
    0
    Вот программа, которая выводит слово в обратном порядке. Об оперативной памяти может не понял, но по-моему оно и так туда сохраняется, по крайней мере во время работы программы:

    Program Task;

    Var s, r: String;

    i: Integer;

    Begin

    WriteLn ('Введите слово:') ;

    ReadLn (s) ;

    SetLength (r, Length (s)) ;

    For i : = 1 To Length (s) Do

    r[i] : = s[Length (s) - i + 1];

    WriteLn ('Результат:') ;

    WriteLn (r) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу для PascalABC, которая выводит слово, введённое с клавиатуры, с буквами в обратном порядке и сохраняет ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Здравствуйте. Помогите сделать задачу на PascalABC, попросили сделать с помощью записей. Составить программу, которая вводит данные о студентах: № п/п, фамилию, год рождения, пол, курс, вид спорта и выводит: выводит данные только о спортсменках по
Ответы (1)
1) Проверка условия и ветвление в алгоритме. Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а) удвоенное значение числа, если число положительное; б) абсолютное значение числа, если число отрицательное.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)