Задать вопрос
17 декабря, 05:25

Для любого целого k обозначим количество цифр в его десятичной записи через N (k). Дано натуральное число m. Вычислить:

Нужно написать код для паскаля!

+2
Ответы (1)
  1. 17 декабря, 05:33
    0
    Var x: real;

    i, j, m: integer;

    function N (i: integer) : integer;

    begin

    result : = length (inttostr (i)) ;

    end;

    begin

    readln (m) ;

    for i : = 1 to m do

    x : = x + N (i) / sqr (i) ;

    writeln (x) ;

    end.

    Я не совсем понял про "количество цифр в десятичной записи", но, если неправильно сделал, легко исправить, напишите мне =)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для любого целого k обозначим количество цифр в его десятичной записи через N (k). Дано натуральное число m. Вычислить: Нужно написать код ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Необходимо решить следующую предметную задачу и написать программу на языке Паскаль. Для любого целого k обозначим количество цифр в его десятичной записи Ц (k). Например: Ц (1) = 1, Ц (9) = 1, Ц (10) = 2. Дано натуральное число n.
Ответы (1)
1. Найти разность 31 (10) - 16 (10) в восьмибитном представлении. Прямой код, обратный код и дополнительный код. 2. Представить число - 292 (10) в двоичном виде в шестнадцатибитном представлении в формате целого со знаком.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)