Задать вопрос
3 декабря, 19:45

Необходимо решить следующую предметную задачу и написать программу на языке Паскаль. Для любого целого k обозначим количество цифр в его десятичной записи Ц (k).

Например: Ц (1) = 1, Ц (9) = 1, Ц (10) = 2. Дано натуральное число n. Вычислить:

(Ц (1) / 1) + (Ц (2) / 2^2) + ... + (Ц (n) / n^2)

+2
Ответы (1)
  1. 3 декабря, 22:03
    0
    program crash;

    var n, k: integer;

    r: real;

    begin

    write ('n = ') ;

    readln (n) ;

    k : = 0;

    r : = 0;

    while n > 0 do

    begin

    k : = k + 1;

    r : = r + (n mod 10) / (k * k) ;

    n : = n div 10

    end;

    writeln ('r = ', r:0:14) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Необходимо решить следующую предметную задачу и написать программу на языке Паскаль. Для любого целого k обозначим количество цифр в его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для любого целого k обозначим количество цифр в его десятичной записи через N (k). Дано натуральное число m. Вычислить: Нужно написать код для паскаля!
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)