Задать вопрос
3 ноября, 07:23

Дан массив B размерности N. Найти произведение положительных четных элементов массива.

+2
Ответы (2)
  1. 3 ноября, 08:49
    0
    Progra gt;

    var b:array[1 ... 10000] of integer;

    n, i, p:linteger;

    begin

    read (n) ;

    p:=1;

    for i:=1 to n do

    begin

    read (b[i]) ;

    if (b[i]>0) and (b[i] mod 2=0) then p:=p*b[i];

    end;

    writeln (p) ;

    end.
  2. 3 ноября, 09:30
    0
    VB.

    Dim B () As Integer

    Randomize ()

    Dim k As Integer

    Dim i As Integer

    Dim Summ as Long

    Summ=1

    i = InputBox ("Введите N")

    ReDim A (i)

    For k = 0 To i

    B (k) = Rnd () * - 1000 + 500

    If B (k) > 0 and B (k) mod 2 = 0 then Summ=Summ*B (k)

    Next

    MsgBox (Summ)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив B размерности N. Найти произведение положительных четных элементов массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)