Задать вопрос
19 октября, 17:46

Каждый солнечный день улитка сидящая на дереве поднимается на 2 см а в каждый пасмурный день опускается на 1 см. в начале ноября улитка находилась ы А см от земли на В дереве. имеется 30 элем. массив содержащим сведенья о том был ли соответствующий деньпасмурным или солнечным. написать программу определяющее место положения улитки к концу 30 дня наблюдения

+1
Ответы (1)
  1. 19 октября, 19:53
    0
    Program Ulitka;

    Var SunnyDay: Array [1 ... 30] Of Boolean;

    a, b, c, i: Integer;

    Begin

    WriteLn ('a = ') ;

    ReadLn (a) ;

    WriteLn ('b = ') ;

    ReadLn (b) ;

    b : = b * 100;

    Randomize;

    For i : = 1 To 30 Do

    Begin

    If Random (2) = 1 Then

    SunnyDay[i] : = True

    Else

    SunnyDay[i] : = False;

    End;

    For i : = 1 To 30 Do

    Begin

    If SunnyDay[i] = True Then

    Begin

    a : = a + 2;

    If a > b Then

    a : = b;

    End

    Else

    Begin

    a : = a - 1;

    If a < 0 Then

    a : = 0;

    End;

    End;

    WriteLn ('Дни месяца были таковы:') ;

    For i : = 1 To 30 Do Begin

    If SunnyDay[i] = True Then

    WriteLn (i, '. Солнечный')

    Else

    WriteLn (i, '. Пасмурный')

    End;

    WriteLn ('К концу 30 дня местоположение улитки равно ', a, ' см над землей') ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Каждый солнечный день улитка сидящая на дереве поднимается на 2 см а в каждый пасмурный день опускается на 1 см. в начале ноября улитка ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1 Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см, а каждый пасмурный день опускается вниз на 1 см, В начале наблюдения улитка находится в A см от земли на B-метровом дереве.
Ответы (1)
Каждый солнечный день улитка сидящая на дереве поднимается вверх на 2 см а в пасмурный день опускается на 10 см. в начале недели улитка находилась на а см от земли и на в метровом дереве.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Исполнитель улитка живет на вертикальной числовой оси. Система команд исполнитель 1. Вверх 4 (улитка поднимается вверх на 4 единицы) 2.
Ответы (1)
Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив.
Ответы (1)