Задать вопрос
22 апреля, 23:34

Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M (включительно).

+5
Ответы (1)
  1. 23 апреля, 02:40
    0
    Var

    i, k, m, j:integer;

    a, b:array[1 ... 10]of integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (50) ;

    write (a[i]:3) ;

    end;

    writeln;

    write ('Введите k и m: ') ;

    readln (k, m) ;

    j:=m;

    for i:=k to m do

    begin

    b[j]:=a[i];

    j:=j-1;

    end;

    for i:=k to m do a[i]:=b[i];

    writeln ('Измененный массив:') ;

    for i:=1 to 10 do write (a[i]:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M (включительно), влево на R элементов.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Уровень C. Напишите программу, которая заполняет массив из N = 10 случайными числами в диапазоне [10,50], выводит его на экран, а затем выполняет реверс отдельно первой и второй половин массива.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)