Задать вопрос
5 июня, 21:58

Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M (включительно), влево на R элементов.

+2
Ответы (1)
  1. 6 июня, 00:22
    0
    Var

    i, k, m, r, p, j:integer;

    a:array[1 ... 10]of integer;

    begin

    writeln ('Массив: ') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (10) ;

    write (a[i],' ') ;

    end;

    writeln;

    write ('Введите K, M, R: ') ;

    readln (k, m, r) ;

    for i:=1 to r do

    begin

    j:=k;

    p:=a[j];

    while j
    begin

    a[j]:=a[j+1];

    j:=j+1

    end;

    a[j]:=p;

    end;

    writeln ('Измененный массив:') ;

    for i:=1 to 10 do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M (включительно).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Создайте целочисленный массив размерностью N. Введите значения элементов массивов с клавиатуры. Выполните циклический сдвиг значений элементов массива на k позиций вправо (в сторону увеличения индексов элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)