Задать вопрос
9 июня, 23:15

Дана последовательность из n целых чисел. Найти среднее арифметическое этой последовательности.

+2
Ответы (1)
  1. 9 июня, 23:33
    0
    Program D1KPxx16;

    uses crt;

    var

    a, sr:real;

    i, n:integer;

    begin

    read (n) ;

    for i:=1 to n do

    begin

    read (a) ;

    sr:=sr+a;

    end;

    sr:=sr/n;

    writeln (sr) ;

    end.

    все числа вводятся вручную, первое число-кол-во чисел, далее эти числа.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность из n целых чисел. Найти среднее арифметическое этой последовательности. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)
Дано натуральное n и последовательность чисел x1, x2, ..., xn. Вычислить среднее арифметическое членов последовательности. В первой строке содержится целое число n (1≤n≤100) - количество членов последовательности.
Ответы (1)
Паскаль: Дана последовательность целых чисел, ввод последовательности заканчивается 0 (до первого введенного нуля), найти среднее арифметическое чисел из последовательности
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)