Задать вопрос
9 декабря, 23:37

Дан массив Array[1 ... 100]

С помощью цикла присвоить, каждому элементу массива значение равное номер элемента умноженный на 3. например для массива А значение элемента А[1]=2, A[2]=6 A[3]=9 и т. д. В конце программа должна выводить на экран сумму всех элементов массива.

+2
Ответы (1)
  1. 9 декабря, 23:52
    0
    Var A : array[1 ... 100] of integer;

    var i, S : integer;

    begin

    for i:=1 to 100 do A[i]:=i*3;

    S:=0;

    for i:=1 to 100 do S:=S+A[i];

    Writeln ('сумма элементов массива = ', s) ;

    end.

    или без лишнего цикла можно так

    var A : array[1 ... 100] of integer;

    var i, S : integer;

    begin

    for i:=1 to 100 do

    begin

    A[i]:=i*3;

    S:=S+A[i];

    end;

    Writeln ('сумма элементов массива = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив Array[1 ... 100] С помощью цикла присвоить, каждому элементу массива значение равное номер элемента умноженный на 3. например ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)