Задать вопрос
8 февраля, 07:55

Написать программу в паскале: Дано натуральное число n. Заменить порядок следования цифр числа n на обратный.

+3
Ответы (2)
  1. 8 февраля, 08:53
    0
    Var a, N: integer;

    begin

    writeln ('Введите число') ;

    readln (N) ; a:=0;

    while N>0 do begin

    a:=a*10+N mod 10;

    N:=N div 10;

    end;

    writeln (a) ;

    readln;

    end.
  2. 8 февраля, 11:38
    0
    Var

    n, x:string;

    i:integer;

    begin

    write ('Введите число n: ') ;

    readln (n) ;

    for i:=length (n) downto 1 do x:=x+n[i];

    writeln ('Обратное число: ', x)

    end.

    или можно так:

    var

    n:string;

    begin

    write ('Введите число n: ') ;

    readln (n) ;

    writeln ('Обратное число: ', ReverseString (n))

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале: Дано натуральное число n. Заменить порядок следования цифр числа n на обратный. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Программу на с++ Даны натуральное число n, действительные числа а1, ..., аn. Преобразовать последовательность al, ..., аn, расположив вначале отрицательные члены, а затем-неотрицательные.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)